Website DDoS Attack
Incident Report for We Leak Info
Resolved
This incident has been resolved.
Posted 15 days ago. Sep 06, 2019 - 01:14 EDT
Monitoring
Our team has successfully implemented a fix and the website is now fully operational. We will continue to monitor the site closely for the next few hours.
Posted 15 days ago. Sep 06, 2019 - 01:12 EDT
Identified
We have identified an ongoing DDoS attack on the website. Our team is working to mitigate it.
Posted 15 days ago. Sep 06, 2019 - 01:07 EDT
This incident affected: Website.